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Abstract
This is the user’s guide to Windows Notepad — a text editor that comes pre-installed with the Microsoft Windows operating system. The purpose of this document is to cover basic user procedures. To learn about all Windows Notepad features, please, refer to Microsoft documentation.
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[bookmark: _Toc108409671]Introduction
Windows Notepad (or Notepad, as referred to further in this guide) is a text editor, or text processing tool, that you can use to create, view, and modify files that contain human readable text also known as plain text. 
Note: Plain text can be interpreted by a person as well as by a software application.
[bookmark: _Toc108409672]Notepad features
With Notepad you can:
· edit plain text,
· search and replace data in files,
· save files in different encodings and character sets.
[bookmark: _Toc108409673]Which files you can view and edit with Notepad
In Microsoft Windows
The types of texts that you can view and edit in Notepad include but not limited to:
· regular texts in natural languages;
· texts written in markup languages (for example: HTLM, XML-based texts, wiki markup, etc.);
· [bookmark: _GoBack]software configuration settings (for example: INI, CFG, etc.);
· programming source code (for example: JavaScript).
See Table. 1 below.
[bookmark: _Ref108386751]Table. 1
	Type of text
	Description
	Example

	Natural language
	Files that contain texts in natural languages usually have the .txt extension and can contain notes, reminders, instructions — anything that a person writes to themselves or to any other person to read.
By default, the files with the .txt extensions are opened in Notepad.
	The quick brown fox jumps over the lazy dog.

	Markup
	A markup language uses special notation so that it could be parsed and/or rendered by an application or a service.
For example, HTML files have the .html (or .htm) extension and by default are opened by Internet browsers. So, if you double click a file with the .html extension in Windows Explorer, it will normally open in your default Internet browser. 
However, you can also open and edit these files in Notepad — for example, to add some minor changes.
	HTML example
	<!DOCTYPE html>
<html>
<body>

<h1>My First Heading</h1>
<p>My first paragraph.</p>

</body>
</html>


wiki markup example
	== New section ==
A single
newline
=== Subsection ===
* Unordered Lists are easy to do:
** start every line with a star
*** more stars means deeper levels




	Software configuration
	Different applications, like system utility programs or even computer games, often use text files to store editable configuration settings.
The common extensions used with these files are .ini, .cfg, .config, etc.
You can edit configuration files in Notepad make some performance tweaks.
	Example of an INI file
	; last modified 1 April 2001 by John Doe
[owner]
name = John Doe
organization = Acme Widgets Inc.

[database]
; use IP address in case network name resolution is not working
server = 192.0.2.62     
port = 143
file = "payroll.dat"




	Source code
	A source code is a set of instructions to a computer. This set of instructions after a process called compilation becomes a program or a part of a program.
You can use Notepad to edit the source code before compiling, however, this is a rare case scenario.
	Example of a source code written in C++ programming language
	#include <iostream>

int main() {
  std::cout << "Hello, World!\n";
  return 0;
}







[bookmark: _Toc108409674]Using Notepad
[bookmark: _Ref108398289][bookmark: _Toc108409675]Starting Notepad
To start Notepad click [image: ] (Start) and select Windows Accessories > Notepad (see the figure below).
[image: ]
Figure. 1 – Starting Notepad
The Notepad window will appear (see the figure below).
[image: ]
Figure. 2 – Notepad is running
[bookmark: _Toc108409676]Opening existing files
You can open existing files from Notepad or from File Explorer (or any other supported file manager):
· see From Notepad below;
· see From File Explorer on page 7.
[bookmark: _Ref108407525][bookmark: _Ref108407528][bookmark: _Toc108409677]From Notepad
To open an existing file from Notepad:
Start Notepad (see Starting Notepad on page 5).
From the Notepad menu select File > Open.
The Open window will appear (see the figure below).
[image: ]
Figure. 3 — Specify the path to the file
Specify the path to the file you want to open and click Open.
Note: By default, only the files with the .txt extension are displayed. To display all files, select All Files in the dropdown menu next to the File name field.
Warning: You can view and edit any file with Notepad, even files that are intended to be only machine-readable (such as .exe, .msi, .dll, etc.). However, modifying the content of such files will corrupt them and make these files unusable. If on doubt, search https://stackoverflow.com/ for answers).
The contents of the file will be displayed in the Notepad window (see the figure below).
[image: ]
Figure. 4 — File contents
[bookmark: _Ref108407531][bookmark: _Ref108407533][bookmark: _Toc108409678]From File Explorer
Files with the .txt extension
To open a .txt file using File Explorer:
Open File Explorer — to do this, use the Win+E keyboard shortcut.
The Windows Explorer will appear (see the image below).
[image: ]
Figure. 5 — File Explorer
Navigate to the file you want to open and double-click it.
The contents of the file will be displayed in the Notepad window (see the figure below).
[image: ]
Figure. 6 — File contents
Files with other extensions
By default, on double-click Microsoft Windows opens in Notepad only files with the .txt extension. To open files with extensions other than .txt:
Open File Explorer — to do this, use the Win+E keyboard shortcut.
The Windows Explorer will appear (see the image below).
[image: ]
Figure. 7 — File Explorer
Right-click on the file you want to open (for example, an HTML file) in Notepad.
Warning: You can view and edit any file with Notepad, even files that are intended to be only machine-readable (such as .exe, .msi, .dll, etc.). However, modifying the content of such files will corrupt them and make these files unusable. If on doubt, search https://stackoverflow.com/ for answers).
In the dropdown menu select Open with > Choose another app (see the figure below).
[image: ]
Figure. 8 — Opening a file with a non-default application
You will be prompted to select an application to open the file (see the figure below).
[image: ]
Figure. 9 — Application selection
Click More apps and select Notepad from the list (see the figure below).
[image: ]
Figure. 10 — Notepad is selected
Select Always use this app to open .html files if you want Notepad to be your default application to open HTML files, otherwise, proceed to the next step of the procedure.
Click OK.
The contents of the file will be displayed in the Notepad window (see the figure below).
[image: ]
Figure. 11 — An HTML file opened in Notepad
[bookmark: _Toc108409679]Viewing options
After a file is opened you can configure the way the contents of this file is displayed in Notepad:
· see Word wrap below;
· see Changing font size on page 11.
[bookmark: _Ref108408214][bookmark: _Toc108409680]Word wrap
If some lines in the opened file do not fit the Notepad window width, you can apply word wrap. If word wrap is enabled, the lines of text are visually broken into separate lines to fit the Notepad window width.
To enable or disable word wrap, select Format > Word Wrap from the Notepad menu (see the image below).
[image: ]
Figure. 12 — Enabling/disabling word wrap 
Below are the examples of how file appears in Notepad with disabled and enabled word wrap.
[image: ]
Figure. 13 — Word wrap disabled
[image: ]
Figure. 14 — Word wrap enabled
[bookmark: _Ref108408224][bookmark: _Toc108409681]Changing font size
If you want to increase or reduce the displayed font size in Notepad, use the following keyboard shortcuts:
· CTRL “+” — to increase the font size.
· CTRL “-“ — to reduce the font size.
Below are the examples of the increased and reduced font size in Notepad.
[image: ]
Figure. 15 — Increased font size
[image: ]
Figure. 16 — Reduced font size
Note: To reset the font size to the default value, use the CTRL + “0” keyboard shortcut.
[bookmark: _Toc108409682]Editing files
To edit a file:
· to create and edit a new file, simply start Notepad (see);
· to edit an existing file, open it using Notepad or File Explorer (see or ).
Notepad offers the following editing options (see the table below).
Table. 2 – Editing options
	Action
	Description

	Add contents
	Place the cursor to a position where you want to add the new contents and do the following:
to add contents manually, type the necessary text.
to paste previously copied contents, press CTRL+V on the keyboard or select Edit > Paste from the Notepad menu.

	Delete contents
	To delete single characters (or blank spaces), place the cursor before the character and press Delete button on keyboard.
To delete a whole word, place the cursor after the word you want to delete and press CTRL+Backspace on the keyboard.
To delete larger sections of text, select them holding the left mouse button (to select the whole text press CTRL+A on the keyboard) and do one of the following:
press Delete on the keyboard;
select Edit > Delete from the Notepad menu.

	Copy and paste
	To copy a portion of text, select it holding down the left mouse button and press CTRL+C on the keyboard (alternatively, select Edit > Copy from the Notepad menu).
To paste the copied contents, place the cursor to a position where you want to add the copied text and press CTRL+V on the keyboard (alternatively, select Edit > Paste from the Notepad menu).

	Find text
	To find some text:
Press CTRL+F on the keyboard (alternatively, select Edit > Find in the Notepad menu).
In the Find dialog specify the text you want to find and click Find Next.

	Replace text
	To replace some text:
Press CTRL+H on the keyboard (alternatively, select Edit > Replace in the Notepad menu).
In the Replace dialog specify the text you want to replace and the replacement text.
Click Replace (to make a single replacement) or Replace All (to replace all entries in the file).


Save changes to the edited file (see Saving files ниже).
Note: If there are unsaved changes in the current file, there is an asterisk (“*”) next to the filename (see the figure below).
[image: ]
Figure. 17 — A file with unsaved changes
[bookmark: _Ref108408781][bookmark: _Toc108409683]Saving files
The procedure differs depending on:
· whether you’re saving a new file or a previously existed one;
· whether you want to save an existing with the same name and/or path or choose different.
	Initial condition
	Description

	If you want to save a newly created file
	Do one of the following:
press CTRL+S on the keyboard;
select File > Save from the Notepad menu;
press CTRL+SHIFT+S on the keyboard;
select File > Save As from the Notepad menu.
In the window that will appear specify the name and the path of the file.
Click Save.
The file is saved.

	If you want to save an existing file with the same name and path
	Do one of the following:
press CTRL+S on the keyboard;
select File > Save from the Notepad menu
The File is saved.

	If you want to save an existing file but change its name and path
	1. Do one of the following:
Press CTRL+SHIFT+S on the keyboard;
Select File > Save As from the Notepad menu.
2. In the window that will appear specify the name and the path of the file.
3. Click Save.
The file is saved.


[bookmark: _Toc108409684]Notepad Uninstallation and Installation
[bookmark: _Toc108409685]Uninstallation
If you want to uninstall Notepad, you can do this using standard Microsoft Windows tools:
1. Click [image: ] (Start) and select Settings (see the figure below).
[image: ]
Figure. 18 — Select Settings
2. In the Settings window select Apps (see the figure below)
[image: ]
Figure. 19 — The Settings window
3. In the Apps and & features section click Optional features (see the image below).
[image: ]
Figure. 20 — The Apps & features section
4. In the Optional features section find Notepad (see the figure below).
[image: ]
Figure. 21 — Optional features
5. Сlick Uninstall.
[bookmark: _Toc108409686]Installation
If you want to uninstall Notepad, you can do this using standard Microsoft Windows tools:
1. Click [image: ] (Start) and select Settings (see the figure below).
[image: ]
Figure. 22 — Select Settings
2. In the Settings window select Apps (see the figure below)
[image: ]
Figure. 23 — The Settings window
3. In the Apps and & features section click Optional features (see the figure below).
[image: ]
Figure. 24 — The Apps & features section
4. In the Optional features window click Add a feature (see the figure below).
[image: ]
Figure. 25 — The Optional features section
5. In the Add an optional feature section find and select Notepad (see the figure below).
[image: ]
Figure. 26 — Install Notepad
6. Click Install at the bottom of the section.


Appendices
[bookmark: _Toc108409687]Notepad Menu
Notepad menu gives you access to the following features/actions.
Table. 3 - Notepad menu
	Menu
	Option/submenu
	Description

	File
	New
	Creates a new file in the same window. If there are unsaved changes in the current file, Notepad will prompt you to save them.

	
	New Window
	Creates a new file in a new window.

	
	Open
	Opens an existing file. Choosing this option displays a dialog that allows you specify the path to an existing file.

	
	Save
	Saves the current file. If it’s a new file, you will be prompted to specify the path and the name of the file (similar to Save As option).

	
	Save As
	Allows you to save the current file in a different location and with a different name and/or extension.

	
	Page Setup
	Choosing this option displays a setup window where you can configure how your file will be printed.

	
	Print
	Choosing this option displays a window where you can configure printing options and then print the contents of the file.

	
	Exit
	Exits Notepad.

	Edit
	Undo
	Undo a recent change.

	
	Cut
	Deletes the selected portion of text and puts it in the buffer from where you can paste it anywhere in the current file, in another file, or in another application.

	
	Copy
	Copies the selected portion text in the buffer from where you can paste it anywhere in the current file, in another file, or in another application.

	
	Paste
	Insert a previously copied text into the current file at the cursor position.

	
	Delete
	Deletes the selected portion of text.

	
	Search with Bing
	Searches the selected portion of text in the Bing search engine using your default Internet browser.

	
	Find
	Displays a search dialog that you can use to search for data within the current document.

	
	Find Next
	Searches for the next entry that matches the selected portion of text.

	
	Find Previous
	Searches for the previous entry that matches the selected portion of text.

	
	Replace
	Displays a find-and-replace dialog where you can specify some text to be searched and some text to replace the searched matches.

	
	Go To
	Displays a dialog where you can specify the number of the line in the current file — the cursor will be placed at the beginning of the specified line.

	
	Select All
	Selects all text in the current file.

	
	Time/Date
	Inserts the current time and date (in the format set in your system regional settings) at the cursor position.

	Format
	Word Wrap
	If enabled, paragraphs (sections of text divided by Enter) are visually broken into separate lines to fit the Notepad window width.

	
	Font
	Displays a window where you can configure the font parameters, such as font size, style etc. This also affects how the file will be printed.
Note: These settings apply to the whole contents of the file. You cannot change the font of some selected portions of the text being edited.

	View
	Zoom
	This subsection contains three options:
· Zoom In — visually increases the size of the characters in the text.
· Zoom Out — visually reduces the size of the characters in the text.
· Restore Default Zoom — restores the default size of the text if it was changes by Zoom In or Zoom Out.
Note: These settings do not affect how the file will be printed. To change font settings for printing, use Format > Font.

	
	Status Bar
	Shows/hides Notepad status bar at the bottom of the application window.

	Help
	View Help
	Searches for help pages related to Notepad in the Bing search engine using your default Internet browser.

	
	Send Feedback
	Displays a window that you can use to send your feedback to the vendor.
Note: Feedback Hub application must be installed.

	
	About Notepad
	Displays information about Notepad and the current version of Microsoft Windows.
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